First Data - Rapid Connect and Concord EFS - Degraded Performance
Incident Report for Cayan
Resolved
The First Data - Rapid Connect and Concord EFS service issue has been resolved.
Posted 18 days ago. Apr 09, 2017 - 01:19 EDT
Identified
First Data has confirmed the issue and are actively working to resolve.
Posted 18 days ago. Apr 09, 2017 - 00:37 EDT
Investigating
Cayan’s network monitoring has uncovered that First Data - Rapid Connect and Concord EFS may be experiencing intermittent service disruptions at this time. The Cayan network operations center is contacting First Data - Rapid Connect and Concord EFS and will update this incident with additional information as it becomes available.

PLEASE NOTE: The Cayan Gateway is fully operational and continues to process transactions normally.

Only merchants who use First Data - Rapid Connect and Concord EFS are affected by this incident. We advise that merchants using First Data - Rapid Connect and Concord EFS attempt a transaction prior to contacting our help desk.
Posted 18 days ago. Apr 09, 2017 - 00:00 EDT
This incident affected: Payment Processor Partners (Rapid Connect Nashville, Rapid Connect North).